Vulnérabilité dans XRDP

Une vulnérabilité a été découverte dans XRDP, implémentation libre du protocole de bureau à distance RDP. Un attaquant distant peut provoquer un déni de service, exécuter du code arbitraire, ainsi que provoquer une situation permettant l’écoute de mots de passe utilisateur.

CVE-2020-4044 [Score CVSS v3 : 7.8] : Une vulnérabilité de type dépassement de tampon a été découverte dans XRDP. Un attaquant distant peut provoquer un déni de service, ainsi que potentiellement exécuter du code arbitraire, via l’envoi de paquets spécialement conçus au service sesman. Le plantage de ce service peut ensuite être exploité par un attaquant local sur le serveur afin d’exécuter son propre service, pouvant être utilisé afin de capturer des identifiants utilisateur.

Informations
+

Risques

  • Déni de service

  • Exécution de code arbitraire

  • Capture d’identifiants utilisateur

Criticité

  • Score CVSS v3 : 7.8

Existence d’un code d’exploitation

  • Aucun code d’exploitation n’est disponible publiquement à ce jour

Composants vulnérables

  • XRDP avant la version 0.9.13.1

CVE

  • CVE-2020-4044


Recommandations
+

Mise en place de correctifs de sécurité

  • Mettre à jour XRDP vers la version 0.9.13.1 ou supérieure

Solution de contournement

  • Aucune solution de contournement n’est disponible