Vulnérabilité dans GraphicsMagick (lecture / modification d’images)

Une vulnérabilité a été découverte dans GraphicsMagick, un outil de lecture et modification d’images. Elle peut permettre à un attaquant de provoquer un déni de service.

CVE-2020-12672 [Score CVSS v3 : 7.5] : Une vulnérabilité de type débordement de tas a été découverte dans la fonction ReadMNGImage de GraphicsMagick. Un attaquant distant exploitant cette vulnérabilité peut provoquer un déni de service.

Informations
+

Risques

  • Déni de service

Criticité

  • Score CVSS v3 : 7.5

Existence d’un code d’exploitation

  • Un code d’exploitation est disponible publiquement

Composants vulnérables

  • GraphicsMagick toutes versions jusqu’à la 1.3.35

CVE

  • CVE-2020-12672


Recommandations
+

Mise en place de correctifs de sécurité

  • Des correctifs ont été apportés par différentes distributions telles que OpenSUSE ou Debian. Nous vous conseillons de mettre à jour dès que possible vos paquets GraphicsMagick.

Solution de contournement

  • Aucune solution de contournement n’est disponible