Plus de 25 000 routeurs Linksys Smart Wifi toujours vulnérables à une faille de 2014

Selon un rapport des experts sécurité de Bad Packets, une vulnérabilité datant de 2014 continuerait d'impacter un peu plus de 25 000 routeurs Linksys Smart Wi-Fi dans le monde. En effet, la CVE-2014-8244 n'a depuis été que partiellement corrigée et les périphériques impactés restent aujourd’hui toujours vulnérables.

Cette vulnérabilité a été découverte par les chercheurs Kyle Lovett et Sijmen Ruwhof et rendue publique pour la première fois le 31 octobre 2014. L’équipe de Bad Packet a depuis contacté les équipes de sécurité Linksys pour remonter le problème, mais il semblerait que l’éditeur n’ait pas prévu pour l'instant de corriger cette vulnérabilité.

La CVE-2014-8244 est cependant considérée comme critique. Un attaquant pourrait l’exploiter afin de récupérer des informations sensibles concernant le routeur et les périphériques qui se sont déjà connectés au réseau. Cette attaque serait peu complexe à mettre en œuvre et ne nécessiterait pas d’authentification. L’impact estimé sur la confidentialité des données est élevée.

Cette vulnérabilité serait aujourd'hui activement exploitée et des balayages massifs sur ces routeurs vulnérables ont été relevés dans le cadre d’une étude sur un « pot de miel » (honey pot).

Détails techniques :

CVE-2014-8244 [CVSS V3 : 7.5] : Un attaquant pourrait effectuer des requêtes JNAP (utilitaire pour pour tester la connectivité du réseau) pour lire ou modifier des informations sensibles sur le routeur telles que l’adresse MAC, le nom et le système d’exploitation des périphériques connectés. Aucune interaction utilisateur n’est requise et l’exploitation est réalisable à distance et sans privilège.

De ce fait, un attaquant ayant récupéré l’adresse MAC d’une victime est capable de le géolocaliser à l’aide d’outils comme WiGLE. En effet, ce site répertorie tous les points d’accès WiFi avec leurs adresses MAC.

L'accès administrateur au routeur Wi-Fi Linksys Smart Wi-Fi permet ainsi aux attaquants :

  • D'obtenir le mot de passe SSID et Wi-Fi en texte clair ;
  • De modifier les paramètres DNS pour utiliser un serveur DNS malveillant afin de détourner le trafic Web ;
  • D'ouvrir les ports du pare-feu du routeur pour cibler directement les périphériques derrière les routeurs (exemple : 3389/TCO pour Windows Remote Desktop Protocol) ;
  • D'utiliser le protocole UPnP pour rediriger les requêtes sortantes vers le périphérique des attaquants ;
  • De créer un compte OpenVPN (modèles pris en charge) pour acheminer le trafic malveillant à travers le routeur ;
  • De désactiver la connexion Internet du routeur ou modifier d'autres paramètres.
Informations
+

Risques

  • Exécution de code arbitraire.
  • Atteinte à la confidentialité des données

Criticité

  • Score CVSS : 7.5

Existence d’un code d’exploitation de la vulnérabilité

  • L’exploitation de la vulnérabilité est expliquée dans le bulletin de sécurité.

Composants & versions vulnérables

  • E1200 version =< 1.0.04 (build 1) et =< 2.0.11 (build 1)
  • E4200 version =< 1.0.06 (build 3) et =< 2.1.41 (build 164606)
  • EA2700 version =< 1.1.40 (build 189581)              
  • EA2750 version =< 1.1.8 (build 184154)
  • EA3500 version =< 1.1.40 (build 162464)              
  • EA4500 version =< 2.1.42 (build 183584) 3.1.7 (build 181919)
  • EA5800 version =< 1.1.6.186296           
  • EA6100 version =< 1.1.6 (build 181939)
  • EA6200 version =< 1.1.41 (build 188556)              
  • EA6300 version =< 1.1.40 (build 184085)              
  • EA6350 version =< 3.1.10.191322         
  • EA6400 version =< 1.1.40 (build 184085)              
  • EA6500 version =< 1.1.40 (build 176451)              
  • EA6700 version =< 1.1.41 (build 183873)              
  • EA6900 version =< 2.0.3.186963            1.1.43 (build 182871)
  • EA7300 version =< 1.1.4.192824           
  • EA7400 version =< 2.0.7.191563 et =< 1.1.5.190349
  • EA7500 version =< 2.0.7.191563 et =< 1.1.5.190349
  • EA8100 version =< 1.0.2.193233           
  • EA8300 version =< 1.1.4.191539           
  • EA8500 version =< 1.1.9.192968           
  • EA9200 version =< 1.1.9 (Build 183676)
  • EA9300 version =< 1.1.9.183697           
  • EA9400 version =< 1.0.3.181249           
  • EA9500 version =< 2.1.1.186574 et =< 1.1.7.180968
  • WRT1200AC version =< 2.0.6.191786 et =< 1.0.5.187766
  • WRT1900AC version =< 2.0.8.187766 et =< 1.1.10.187766
  • WRT1900ACS version =< 2.0.2.188405 et =< 1.0.3.187766
  • WRT3200ACM version =< 1.0.6.186168
  • XAC1200 version =< 1.1.42.166111       
  • XAC1900 version =< 1.1.42.162280
  • WHW03 version =< 1.1.8.192419 et 2.1.8.192419

CVE

  • CVE-2014-8244

Recommandations
+

Mise en place de correctif de sécurité

  • Aucun correctif n’a été publié.

Solution de contournement

  • Aucune solution de contournement n’est proposée.